re = /^(?!_)(?!.*_$)[a-zA-Z0-9_]+$/m
str = 'Valid Entries:
abc
ABC
Abc123
123a
Abc_12
Abc_12_3a
abc_23_43_fg
Invalid Entries:
_abc
abc_
_abc_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end