using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*V2|.*WebResource)(.*)\.Time$";
string input = @"BumpCardV2Resource.getInstance.Time
BumpCardWebResource.getInstance.Time
BumpCardResource.getInstance.Time";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}