$re = '/^(?!.*V2|.*WebResource)(.*)\.Time$/m';
$str = 'BumpCardV2Resource.getInstance.Time
BumpCardWebResource.getInstance.Time
BumpCardResource.getInstance.Time';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);