$re = '/(?<=id=)[^&]+/m';
$str = ' http://example.com?id=some.thing.com&other=parameter
http://example.com?id=some.thing.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);