re = /(?<=id=)[^&]+/m
str = ' http://example.com?id=some.thing.com&other=parameter
http://example.com?id=some.thing.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end