#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^\s*(\w+)\s*\{"
Local $sString = " solvers " & @CRLF & _
" { " & @CRLF & _
" p" & @CRLF & _
" { " & @CRLF & _
" solver PCG; " & @CRLF & _
" preconditioner DIC; " & @CRLF & _
" tolerance 1e-06; " & @CRLF & _
" relTol 0.05; " & @CRLF & _
" } " & @CRLF & _
"..." & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")