re = /^\s*(\w+)\s*\{/
str = ' solvers
{
p
{
solver PCG;
preconditioner DIC;
tolerance 1e-06;
relTol 0.05;
}
...
}'
# Print the match result
str.match(re) do |match|
puts match.to_s
end