# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(.*?) => (\d+)(?: *\R|$)"
test_str = ("0 => 129367\n"
"1 => 998023\n"
"2 => 971513\n"
"3 => 365366\n"
"4 => 247647\n"
"5 => 131747\n"
"6 => 86151\n"
"7 => 898342\n"
"8 => 591121\n"
"9 => 828966\n"
"a => 185363\n"
"b => 420016\n"
"c => 472728\n"
"d => 185475\n"
"e => 669058\n"
"f => 472944\n"
"g => 932915\n"
"h => 109171\n"
"i => 940561\n"
"j => 483250\n"
"k => 240419\n"
"l => 158223\n"
"m => 494635\n"
"n => 205943\n"
"o => 19961\n"
"p => 989725\n"
"q => 125777\n"
"r => 195604\n"
"s => 818227\n"
"t => 83779\n"
"u => 990539\n"
"v => 639213\n"
"w => 669743\n"
"x => 546240\n"
"y => 950155\n"
"z => 631005\n"
"A => 126161\n"
"B => 403898\n"
"C => 323151\n"
"D => 536228\n"
"E => 653494\n"
"F => 810236\n"
"G => 808261\n"
"H => 900915\n"
"I => 60916\n"
"J => 417663\n"
"K => 371534\n"
"L => 384244\n"
"M => 900004\n"
"N => 300998\n"
"O => 346538\n"
"P => 5044\n"
"Q => 558707\n"
"R => 404479\n"
"S => 183163\n"
"T => 505254\n"
"U => 497969\n"
"V => 197795\n"
"W => 953877\n"
"X => 394637\n"
"Y => 760236\n"
"Z => 211436\n"
"! => 601326\n"
"\" => 15745\n"
"# => 428427\n"
"$ => 602548\n"
"% => 938126\n"
"& => 159405\n"
"' => 528113\n"
"( => 8021\n"
") => 910309\n"
"* => 747795\n"
"+ => 232242\n"
", => 731593\n"
"- => 808534\n"
". => 429705\n"
"/ => 916854\n"
": => 241543\n"
"; => 755104\n"
"< => 314595\n"
"= => 398161\n"
"> => 606925\n"
"? => 804662\n"
"@ => 713498\n"
"[ => 431477\n"
"\\ => 80381\n"
"] => 36645\n"
"^ => 156790\n"
"_ => 34787\n"
"` => 107682\n"
"{ => 283663\n"
"| => 650856\n"
"} => 91921\n"
"~ => 752056\n"
" => 494223\n"
" => 521932\n\n"
" => 816279\n"
" => 301703\n"
" => 17163\n"
" => 867641\n"
"ą => 817209\n"
"ś => 594615\n"
"ż => 570356\n"
"ź => 913303\n"
"ł => 752084\n"
"ó => 838178\n"
"ę => 693877\n"
"ń => 564418\n"
"ć => 30975\n"
"Ż => 707466")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.