$re = '/\n *(?=[a-zA-Z])/m';
$str = 'this is
a line wrap
this
6isn\'t';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;