re = /\n *(?=[a-zA-Z])/m
str = 'this is
a line wrap
this
6isn\'t'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result