package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(.+?:[\/\\]+)`)
var str = `dec:/file1.texdec:/file2.srcdec:/file3.ltx\ndec:/file4.dtxdec:/file5.insdec:/file6.src
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}