import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.+?:[\\/\\\\]+)(?:(?!\\1).)*";
final String string = "dec:/file1.texdec:/file2.srcdec:/file3.ltx\\ndec:/file4.dtxdec:/file5.insdec:/file6.src\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}