const regex = /(.+?:[\/\\]+)(?:(?!\1).)*/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.+?:[\\\/\\\\]+)(?:(?!\\1).)*', 'mg')
const str = `dec:/file1.texdec:/file2.srcdec:/file3.ltx\\ndec:/file4.dtxdec:/file5.insdec:/file6.src
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);