$re = '/^(?!.*xeditor).*\.css$/m';
$str = 'globalsite/xeditor/styles.css
globalsite/editor/styles.css';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);