re = /^(?!.*xeditor).*\.css$/m
str = 'globalsite/xeditor/styles.css
globalsite/editor/styles.css'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end