import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Major\\s+(?<major>\\w+)\\s+(?<message>.*)";
final String string = "Major SIPCM *SipCmRecvFromTcpSocket: Error in reading data on socketId 247, errno=104\n"
+ "Major NRS ARP lookup for 216.20.237.19 on interface pkt0 with addrContextId 1 failed: SIOGARP error , error 6\n"
+ "Major LVM *NpMediaYmacRespHdlr: error code 0x3 recvd for bcm cmd 4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}