re = /^Major\s+(?<major>\w+)\s+(?<message>.*)/m
str = 'Major SIPCM *SipCmRecvFromTcpSocket: Error in reading data on socketId 247, errno=104
Major NRS ARP lookup for 216.20.237.19 on interface pkt0 with addrContextId 1 failed: SIOGARP error , error 6
Major LVM *NpMediaYmacRespHdlr: error code 0x3 recvd for bcm cmd 4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end