import re
regex = re.compile(r"(?<=^ *)(?=\$(?:\{[a-z_][a-z0-9_]*\}|[a-z_][a-z0-9_]*)|[a-z_][a-z0-9_]*)(?:(?:\$\{)?([^ \}]+)\}?)(?= *$)", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("### INFO\n"
"# Attempt to capture a parameter identifier inside a text selection, possibly\n"
"# wrapped in whitespace, including the following (examples using `backtick quotes`):\n"
"# - Raw word: e.g. `param_name`\n"
"# - $parameter expansion: e.g. `$param_name`\n"
"# - ${parameter} expansion e.g. `${param_name}`\n"
"### ENDINFO\n\n"
"testvar\n"
" testvar\n"
" test_var \n"
" test5_var \n"
" test_var5 \n"
" $test_var\n"
" $test_var4\n"
" ${test_var4}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")