const regex = new RegExp('\\{(\\w+)\\}(.*?){/\\1}((?:(?!\\{\\w+\\}).)*)', 'gm')
const str = `{s}lorem ipsum{/s} explanation for lorem ipsum {s}dolar sit amet{/s} explanation for dolar sit amet`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}