$re = '~\{(\w+)\}(.*?){/\1}((?:(?!\{\w+\}).)*)~m';
$str = '{s}lorem ipsum{/s} explanation for lorem ipsum {s}dolar sit amet{/s} explanation for dolar sit amet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);