package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\([\d]{3}\)\s[\d]{3}-[\d]{4}$`)
var str = `(044) 456-7890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}