$re = '/^\([\d]{3}\)\s[\d]{3}-[\d]{4}$/m';
$str = '(044) 456-7890';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);