$re = '/(\D\d+)$/m';
$str = 'AB1C1
AB2C2
AB3C20';
$subst = "_\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;