import Foundation
let pattern = #"(\D\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AB1C1
AB2C2
AB3C20
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)