$re = '/(?<=^|[^-])\battorney\b(?=[^-]|$)/m';
$str = 'My assistant-attorney wil see you now
The attorney-general was her
my attorney will be calling you';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);