re = /(?<=^|[^-])\battorney\b(?=[^-]|$)/m
str = 'My assistant-attorney wil see you now
The attorney-general was her
my attorney will be calling you'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end