$re = '/(?-s)(^.+\R?)\b\d{2}\.\d{2}\b%(?=((?:\R^.+){2}))/m';
$str = 'tttttttttttyyyyyyyyyyyyyy 28758.gif: 100.00%
tttttttttttyyyyyyyyyyyyyy 28759.gif: 98.92%
tttttttttttyyyyyyyyyyyyyy 28760.gif: 100.00%
tttttttttttyyyyyyyyyyyyyy 28761.gif: 98.54%
tttttttttttyyyyyyyyyyyyyy 28762.gif: 100.00%
tttttttttttyyyyyyyyyyyyyy 28763.gif: 98.85%
tttttttttttyyyyyyyyyyyyyy 28764.gif: 100.00%
tttttttttttyyyyyyyyyyyyyy 28765.gif: 99.91%
tttttttttttyyyyyyyyyyyyyy 28766.gif: 100.00%
tttttttttttyyyyyyyyyyyyyy 28767.gif: 100.00%
tttttttttttyyyyyyyyyyyyyy 28768.gif: 100.00%
tttttttttttyyyyyyyyyyyyyy 28834.gif: 100.00%
tttttttttttyyyyyyyyyyyyyy 28835.gif: 100.00%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);