$re = '/(?<=^|\s)\b.{1,15}\b(?=\s|$)/';
$str = 'Lorem ipsum dolor sit amet consectetur adipiscing elit
Lorem ipsum dolor sit amet consectetur adipiscing el
Lorem ipsum dolor sit amet consectetur adipiscing elit
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);