re = /(?<=^|\s)\b.{1,15}\b(?=\s|$)/
str = 'Lorem ipsum dolor sit amet consectetur adipiscing elit
Lorem ipsum dolor sit amet consectetur adipiscing el
Lorem ipsum dolor sit amet consectetur adipiscing elit
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end