# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)\bhttps?[-\w.\~:/?#[\]@!$&'()*+,;=]+|[@#](\w+)|U\+([A-F\d]{5})"
test_str = ("This is a @ping and a #hash.\n"
"This is a www.example.com, this is http://example.com?asdf=1234#anchor\n"
"https://www.example.net/a/b/c/?g=5&awesome=foobar# U+23232 http://www5.example.com\n"
"https://sub.sub.www.example.org/ @pong@pug#tagged\n"
"http://example.com/@dave\n"
"more http://example.com/more_(than)_one_(parens)\n"
"andU+98765more http://example.com/blah_(wikipedia)#cite-1\n"
"and more http://example.com/blah_(wikipedia)_blah#cite-1\n"
"and more http://example.com/(something)?after=parens")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.