re = /(?i)\bhttps?[-\w.\~:\/?#[\]@!$&'()*+,;=]+|[@#](\w+)|U\+([A-F\d]{5})/
str = 'This is a @ping and a #hash.
This is a www.example.com, this is http://example.com?asdf=1234#anchor
https://www.example.net/a/b/c/?g=5&awesome=foobar# U+23232 http://www5.example.com
https://sub.sub.www.example.org/ @pong@pug#tagged
http://example.com/@dave
more http://example.com/more_(than)_one_(parens)
andU+98765more http://example.com/blah_(wikipedia)#cite-1
and more http://example.com/blah_(wikipedia)_blah#cite-1
and more http://example.com/(something)?after=parens'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end