using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-z0-9]*\?[A-Za-z0-9?]*$";
string input = @"ABC123?A
1ABCA?
?2ABCD
123?34?
?
but not
ABC123
ABC.?1D1
ABC(a)?1d";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}