using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=>)[\+\-]?\d+\.?\d*(?=<)";
string input = @">3.14<
>0.15<
>0.123<
>1234<
>-1.23<
>--4-4-4---.-.-..--..-.-.-<
>.<
>1.<
>0.1<";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}