$re = '/(?<=>)[\+\-]?\d+\.?\d*(?=<)/';
$str = '>3.14<
>0.15<
>0.123<
>1234<
>-1.23<
>--4-4-4---.-.-..--..-.-.-<
>.<
>1.<
>0.1<';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);