using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"spring-.*-\d\.\d.xsd";
string input = @"spring-beans-2.3.xsd
spring-beans-3.0.xsd
spring-beans.xsd";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}