package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`spring-.*-\d\.\d.xsd`)
var str = `spring-beans-2.3.xsd
spring-beans-3.0.xsd
spring-beans.xsd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}