const regex = /^(?:\d+h(?: \d+m)?|\d+m)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\d+h(?: \\d+m)?|\\d+m)$', 'gm')
const str = `45m
1h
2h 45m
2m 45h
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}