$re = '/^(?:\d+h(?: \d+m)?|\d+m)$/m';
$str = '45m
1h
2h 45m
2m 45h
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);