using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^03\d{9}$";
string input = @"03123456789
0312345678
031234567890
04123456789";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}