$re = '/^03\d{9}$/m';
$str = '03123456789
0312345678
031234567890
04123456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);