import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.{0,3}(?:[^\\d\\n]|$)|\\d{4}(?:[^-\\n]|$)).*";
final String string = "abcdef\n"
+ "12345678\n"
+ "1234-5678\n"
+ "abcd-1234\n"
+ "123a-456\n"
+ "1234\n"
+ "123-456\n"
+ "abcd-1234\n"
+ "1234-abcd\n"
+ "1\n"
+ "12\n"
+ "123\n"
+ "1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}