$re = '/^(?:.{0,3}(?:[^\d\n]|$)|\d{4}(?:[^-\n]|$)).*/m';
$str = 'abcdef
12345678
1234-5678
abcd-1234
123a-456
1234
123-456
abcd-1234
1234-abcd
1
12
123
1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);