package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<div>(.+)*<\/div>`)
var str = `<div>asdsdads</div>
<div><div>asdsdads</div></div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}