re = /<div>(.+)*<\/div>/
str = '<div>asdsdads</div>
<div><div>asdsdads</div></div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end