import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^,]*),|,(?=[^,]*$)";
final String string = "101, \"Name1\", \"Designation1\", \"blah1\", \"Blah1\", 20200914001\n"
+ "102, \"Name2\", \"Designation2\", \"blah2\", \"Blah2\", 20200914002\n"
+ "103, \"Name3\", \"Designation3\", \"blah3\", \"Blah3\", 20200914003\n"
+ "104, \"Name4\", \"Designation4\", \"blah4\", \"Blah4\", 20200914004\n"
+ "105, \"Name5\", \"Designation5\", \"blah5\", \"Blah5\", 20200914005";
final String subst = "\\1||";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}