re = /^([^,]*),|,(?=[^,]*$)/m
str = '101, "Name1", "Designation1", "blah1", "Blah1", 20200914001
102, "Name2", "Designation2", "blah2", "Blah2", 20200914002
103, "Name3", "Designation3", "blah3", "Blah3", 20200914003
104, "Name4", "Designation4", "blah4", "Blah4", 20200914004
105, "Name5", "Designation5", "blah5", "Blah5", 20200914005'
subst = '\\1||'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result