using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\B.\B(?=\w*(?:@|\.com))";
string substitution = @"*";
string input = @"userone@domain.com
usertwo@domain.com.co
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}