$re = '/\B.\B(?=\w*(?:@|\.com))/m';
$str = 'userone@domain.com
usertwo@domain.com.co
';
$subst = "*";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;