package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^resource:\/\/((?<flowPackageKey>[a-z0-9]+\.(?:[a-z0-9][\.a-z0-9]*)+)|(?<composerPackageName>[^\/]+\/[^\/]+))(?<path>.*)$`)
var str = `resource://Neos.Neos.Ui/Public/Styles/Host.css
resource://neos/neos-ui-compiled/Public/Styles/Host.css
resource://neos/neos-ui-compiled/Public/Styles/Host.css
resource://Neos.Flow/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}