$re = '/^resource:\/\/((?<flowPackageKey>[a-z0-9]+\.(?:[a-z0-9][\.a-z0-9]*)+)|(?<composerPackageName>[^\/]+\/[^\/]+))(?<path>.*)$/mi';
$str = 'resource://Neos.Neos.Ui/Public/Styles/Host.css
resource://neos/neos-ui-compiled/Public/Styles/Host.css
resource://neos/neos-ui-compiled/Public/Styles/Host.css
resource://Neos.Flow/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);